Page loading delays or difficulties

Minor incident User Platform
2020-12-18 15:33 GMT · 3 hours, 56 minutes, 48 seconds

Updates

Resolved

This has now been resolved.

December 18, 2020 · 19:30 GMT
Issue

Legatics is currently experiencing extremely high levels of demand which may result in some users experiencing page loading delays or difficulties. As a result we will be doubling our server capacity at 18:30 (GMT) today (18 December 2020) to assist with this. This unplanned essential upgrade will result in a period of between 10 to 30 minutes during which Legatics may be unavailable.

December 18, 2020 · 15:37 GMT

← Back